Hi guys, My grandaughter has a 4.3U, never modded,that was knocked off the table with the disk inside and then refused to eject the disk. I took it apart and managed to get the ejection mechanism to work with no undue force by re-aligning one of the white plastic levers. However, after said repair it no longer plays any games. Just gives me the " error has occurred " please turn off,eject & consult manual message. After reading many messages on various forums. I completely disassembled this wii and replaced the following parts, Ribbon cable from motherboard to drive, power cable from motherboard to drive, and disk drive itself. New drive is a D4 which the manufacturer claims is backwards compatible with all models & versions of Wii. I have taken this thing apart three times now and still get the same result. I get a red light when plugged in, a green light when turned on, a flashing blue light when inserting a disk, a screen showing the various wii icons. I do not however get any info on the game that I have inserted,(3 different) just a blank spinning disk and when I click on this I get the error message and everything stops. I can find no loose connections and have inspected everything with a 10x magnifier all to no avail. Anyone out there with more knowledge then me will be appreciated and thank you.