All,

First off, thanks to all who have helped me unknowingly as I searched for answers when I could not get my Wii to connect to my wireless. It was frustrating that my Wii would not connect when computers would connect so easily. So I post this in hopes that it will help someone else who may be facing the same problems as I did. My Wii would say that it was connecting to my wireless, but when it would attempt to download the updates, it would always fail.

So yesterday, I brought home my laptop from work to verify the wireless was working correctly and that the WEP key I was typing in was correct. And just as I thought, the laptop connected fine. So here is what I did to get my router (D-Link 614+) to work with my Wii:

1. goto http://192.168.0.1
2. the user is Admin, and if you haven't ever changed the password, then there is no password. (If your password is blank, you need to change it for security reasons!!)
3. From the home page that comes up, click on the left side where it says "Wireless". There is a small drop down on this page that has channels for the wireless. Mine was on channel 6, and I changed it to channel 1. Make sure that you click "Apply" at the bottom of the page after making every change. The router will restart, so be patient, it will come back in about 45 seconds.
4. I cannot recall exactly where the next one is at, but I think that at the top there is an "Advanced" tab, click on it and there should be a button to the left again that says "Performance". On this page, i changed the transmit and receive speeds to just be normal speeds. this router has a proprietary speed of 22mbps, and that is what I wanted to disable. The radio buttons should be checked that show something like "1,2.5,5,11" not the ones that show "1,2.5,5,11,22". I also disabled lower down on that page where it says "4x". this is also some kind of overspeed. Just disable it.
5. Finally, I clicked on "DMZ" which is the de-militarized zone, or a way of saying, let everything through for a specified ip address. I chose 192.168.0.53 because of my setup for my home network. Because you have to specify a specific address here, it means that you will have to specify the same address on the Wii, and cannot use DHCP to assign the Wii a random address.

That is everything that I did to the router.

Now, on the Wii, when you setup the wireless connection, you have to select manual settings. the manual settings are as follows:

SSID: enter your router's SSID here.
Key: enter your WEP key here
Address: 192.168.0.53
Subnet: 255.255.255.0
Gateway: 192.168.0.1 (router's address)
DNS: 192.168.0.1
000.000.000.000
MTU: 1500

I think that is all of the settings that I entered. After that it tested the connection and started downloading, just like I wanted!!

Hope that this helps someone who is having troubles connecting.

thanks again to everyone on this forum!