1) Disable WEP if you have it set up to see if that is the problem for your inability to connect. If it is, try using a different key(one of should be 4 if you used 64 bit encryption) on the wii if this is the problem. Or just don't use WEP if you don't really have to worry about people tapping into your wireless around your neighborhood.

2) Make sure your router does not have an access list or mac filtering set up, which would block the MAC address of your wii, preventing it from connecting.

3) Try setting your router on channel 6.

4) Buy a new router. Some routers are just naturally bad with games over wifi.