Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Connecting to an 802.11g network

Discussion in 'Nintendo Wii Online' started by Battousai2, Nov 20, 2006.

  1. Battousai2

    Battousai2 WiiChat Member

    Joined:
    Nov 20, 2006
    Messages:
    7
    Likes Received:
    0
    I've been experimenting with connecting my wii to my current network setup (g-only, wpa). What I've found is that it refuses to connect to any 802.11g-based network. When i have my router completely open and set to b-only or mixed, the wii will connect fine. When I test it with g-only it will not connect, giving that common 51330 error. This one setting is all that i need to change to cause it to fail.

    So what'd I'd like to verify is that the wii does in fact support g-only networks and if anyone else has been able to connect like this (to a g-only, NOT mixed).

    My router is a linksys wrt54gs v1.1 running dd-WRT v23 sp1. Thanks for your help.
     
  2. COLDshiver

    COLDshiver Wii Owner

    Joined:
    Sep 14, 2006
    Messages:
    1,084
    Likes Received:
    4
    Location:
    America
    Wii Friend Code: 4532-8683-6668-7765
    4532-8683-6668-7765
    I don't know. My router is currently mixed. I'll try it later to see what happens
     
  3. purana

    purana WiiChat Member

    Joined:
    Dec 19, 2006
    Messages:
    6
    Likes Received:
    0
    Just for the record, I've found the samething too.

    If I have my 802.11g network setup with G only mode and WPA2 security. The Wii never will connect, even when I type in the correct WPA2 key. It just keeps failing with the error 51330 all the time.

    Switch the wireless device into b/g mode and it works fine with b/g mixed mode and WPA2.

    It would lead me to believe the Wii wireless is not 802.11g capable, since it dont work in g only mode.

    Anyone else found something similar or confirmation. I see they class the unit as both b and g capable, but I dont seem to be able to make it work with g mode only with WPA2 security.
     
  4. shady78

    shady78 ninja

    Joined:
    Dec 3, 2006
    Messages:
    33
    Likes Received:
    0
    Location:
    nyc
    Wii Friend Code: 3958-2417-7294-1122
    3958-2417-7294-1122
    I believe the Wii's wifi card is 802.11b only - however, the 802.11g standard allows for backward compatibility with 802.11b - this is why you can enable mixed mode in most 802.11g routers (and have to, in order to get your Wii working with it).
     
  5. purana

    purana WiiChat Member

    Joined:
    Dec 19, 2006
    Messages:
    6
    Likes Received:
    0
    Yeah I know, but this means the specs advertised saying the Wii is 802.11g and 802.11b capable is false. It's only 802.11b (and will only work with 802.11g routers/ap's if placed in mixed mode)

    Just as well I have a number of AP's available to myself, will turn one into a dedicated 802.11b device on a seperate channel to that of my 802.11g network. That way the 802.11g devices don't have to go slow due to the b devices sharing the wireless AP.
     
  6. shady78

    shady78 ninja

    Joined:
    Dec 3, 2006
    Messages:
    33
    Likes Received:
    0
    Location:
    nyc
    Wii Friend Code: 3958-2417-7294-1122
    3958-2417-7294-1122
    Yeah, it's strange. Even their support page recommending routers seems to be inaccurate. See:

    http://www.nintendo.com/consumer/systems/wii/en_na/onlineWirelessRouterChoose.jsp

    From the page:

    What to look for:

    * 802.11G/ 802.11B (or mixed)
    Most routers currently sold offer these settings. Check the box to make sure the router supports these broadcast standards. Routers that mention 802.11N or pre-N (as well MIMO) may not be compatible with the Wii.
     
  7. purana

    purana WiiChat Member

    Joined:
    Dec 19, 2006
    Messages:
    6
    Likes Received:
    0
    Mixed mode is not a good idea, as I believe it slows the 802.11g devices down when the 802.11b devices are using the shared router/access point in mixed mode.

    Oddly enough I have heard from someone else who reckons they can connect to an 802.11g router/ap with WPA2 security. And claim to not using mixed mode. Yet I cant get it to even work unless I enabled mixed mode.

    Anyone else happening to have any further information about what works and what don't works.

    I'd love for the Wii to work with my 802.11g network and wpa2 security mode. Without the need to use mixed mode option. But it appear either the Wii is 802.11b only, or the 802.11g support is not 100%.
     
  8. tank

    tank Semper Ubi Sub Ubi

    Joined:
    Nov 26, 2006
    Messages:
    1,090
    Likes Received:
    21
    Location:
    Pittsburgh, PA
    the only difference between B and G is that one is faster. But I'm pretty sure the Wii is simply not G enabled.
     
  9. purana

    purana WiiChat Member

    Joined:
    Dec 19, 2006
    Messages:
    6
    Likes Received:
    0
    It's probably a little more then just the speed, but we won't go about comparing the spec of each wireless standard.

    I am guessing the fellow who reckons his works on 802.11g with WPA2 actually has mixed mode enabled (and doesn't even realise).
     
  10. JKarp

    JKarp Rabbid Hunter

    Joined:
    Dec 3, 2006
    Messages:
    38
    Likes Received:
    0
    Location:
    Colorado
    Wii Friend Code: 6716-5035-9322-6191
    6716-5035-9322-6191
    The Wii uses an 802.11b driver. Check out one of the disassemby sites and see for yourself. This means mixed mode is required and yes, that does slow 802.11g devices a bit. For any normal DSL or cable connection however, it doesn't make a lick of difference as your Internet connection is still the limiting speed factor.
     
    #10 JKarp, Dec 20, 2006
    Last edited: Dec 29, 2006
  11. tank

    tank Semper Ubi Sub Ubi

    Joined:
    Nov 26, 2006
    Messages:
    1,090
    Likes Received:
    21
    Location:
    Pittsburgh, PA
  12. ToadIsDoingMagicMushrooms

    Joined:
    Dec 4, 2006
    Messages:
    851
    Likes Received:
    1
    Location:
    Northern Ireland - Co. Down
    Wii Friend Code: 8263-8201-5467-9061
    8263-8201-5467-9061
    So what setting should I have it on?
     
  13. domkstaa

    domkstaa WiiChat Member

    Joined:
    Dec 14, 2006
    Messages:
    39
    Likes Received:
    0
    I believe the problem is with WPA TKIP. I'm not able to connect with TKIP as well. Did you give WPA AES a try?
     
  14. cktoss

    cktoss WiiChat Member

    Joined:
    Dec 26, 2006
    Messages:
    1
    Likes Received:
    0
    Only Connects when Using B Only Mode

    I was struggling for the past day to get my Wii to connect and finally found that setting my Netgear WGR614 wireless router to "B" only mode did the trick. I have never had a problem connecting a laptop to my wireless network in the past 2 years in "G and B" mode and I tried what I thought was everything to get the connection right - double checking my WEP code, disabling the WEP encryption, etc and always getting a 51330 error. Finally after reading thru this thread thought I'd give "B" only mode a shot and it worked - shouldn't have but it did.
     
  15. ivandb

    ivandb wii are you doing this

    Joined:
    Dec 26, 2006
    Messages:
    74
    Likes Received:
    0
    wii is B and G i tested

    Im using a belkin router wich does not talk to the wii nomather what i tried but my laptop has no prob so it no receives the signal from my router and send it to the wii troug a HERCULES usb wifi transmiter stick 802.11 G works super now
     
  16. Smokamoto

    Smokamoto WiiChat Member

    Joined:
    Dec 28, 2006
    Messages:
    1
    Likes Received:
    0
  17. ivandb

    ivandb wii are you doing this

    Joined:
    Dec 26, 2006
    Messages:
    74
    Likes Received:
    0
    i use g

    i use a g usb transmitter so i no its G
     
  18. JoeTheZombie

    JoeTheZombie WiiChat Member

    Joined:
    Nov 29, 2006
    Messages:
    123
    Likes Received:
    1
    Location:
    Idaho
    I have a problem with G mode only as well. Here's Nintendo's official response:
     
  19. cryptoZ

    cryptoZ WiiChat Member

    Joined:
    Jan 30, 2007
    Messages:
    1
    Likes Received:
    0
    Wireless-G Working on Linksys WRT54GX4

    I was also having problems connecting to my Linksys WRT54GX4 router. For awhile I was only running successfully in mixed mode, but I then decided to tweak a few of my router settings and was successful in connected to my G-only network after changing two settings.

    First, I set my wireless channel to 1 as was recommended on Nintendo's support site (they suggested using either 1 or 11). Second, I disabled the "Adaptive Channel Expansion" feature. That's what worked for me. Hope it helps.
     
  20. TheCosmicFrog

    TheCosmicFrog WiiChat Member

    Joined:
    Mar 5, 2007
    Messages:
    158
    Likes Received:
    2
    it wont connect to 802.11g for me either
     

Share This Page

Search tags for this page

802.11g wpa2

,

netflix error tvp-802

,
netflix error tvp-851
,

netflix tvp-802

,
netflix tvp-851
,
tvp-802
,

tvp-802 netflix

,
tvp-851
,
tvp-851 netflix
,
wii wifi specs