Wii not Turning On but has Power?


WiiChat Member
Feb 21, 2009
Hi all,

My friend brought me his wii to install a modchip in. It is the first generation, bought it the first day it game out. I have the same wii. I installed a wiikey in mine by soldering but he was scared so he bought a solderless wiiclip. I installed it perfectly and the wii wouldn't turn on. The light is yellow right when I plug it in, not red like it usually is. Then, when I press the power button, it turns red for a split second and then shuts off completely black. I took the wii clip out and the same thing happens. With the DVD player unplugged completely, the system turns on fine. However, when I plug the dvd drive back in, it does the same thing. I unplugged it for 2 hours and tried again. I unplugged the power supply and left it unplugged for an hour and tried again. It is still doing it. I plug it in, the status turns yellow as soon as I plug it in, I press the power button and it just shuts off. The mod chip is not installed but it still doesn't power on. Any hints?
Talking about things that happens to you from mod chips isn't allowed here. It is your fault that you couldn't have just not installed the mod chip and played legally like hard working other people.