Welcome to Our Community

Wanting to join the rest of our members? Feel free to sign up today.

Quad Charger issue

Discussion in 'Nintendo Wii Hardware' started by ddown`, Feb 17, 2010.

  1. ddown`

    ddown` WiiChat Member

    Joined:
    Feb 17, 2010
    Messages:
    1
    Likes Received:
    0
    Location:
    omaha ne
    We have had a Penguin United Quad charger for about a year with no issues.

    Last week one of the remotes quit working so I put standard AA batteries in it and it worked fine.

    A day later all of the other remotes had the same issue so I contacted Penguin United and they sent me 4 new rechargeable batteries.

    Charged them overnight and still the same problem. I did find that if I sqeeze the battery the lights come on and show as fully charged but it is inconsistent. AA batteries work fine.

    Has anyone else had this issue? How to fix? It's weird that this happened to all 4 at the same time after a a year of no problems.

    Any help is appreciated.
     

Share This Page

Search tags for this page
quad wii charger quit working
,
troubleshooting penguin united quad wii charger
,

wii quad charger forum